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Abstract: Electric vehicles are the way of the future. The rising EV market, along with the 

diminishing supply of petroleum fuels, demands the development of more efficient EVs. A battery 

management system (BMS) is an essential component of any electric vehicle. It consists of a 

number of electrical and electronic circuits (including converter and inverter circuits) that have 

been programmed to monitor and extract the maximum output from a battery system. The chemical 

reactions are what determine the battery’s performance. The performance of a battery degrades as 

chemicals decay. As a result, these features of a battery must be regularly monitored. Because of 

their high charge density and lightweight, Lithium-ion batteries have proven to be a popular 

choice among electric vehicle producers. Despite the fact that these batteries have a lot of power 

for their size, they are quite unstable. It is critical that these batteries are never over charged or 

discharged, requiring the use of voltage and current regulators. In this research paper, we will 

monitor various aspects of the vehicles like current, Voltage, SOC and temperature with the help of 

Node MCU which is the Wi-fi enabled microchip that will send the data or crucial parameters to 

the server which is the Thing Speak. Therefore in this way we can monitor these parameters from 

anywhere and also monitor battery health. 
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I.INTRODUCTION 

 Electric vehicle (EV) is one that is made to run by an electric motor rather than an internal-combustion engine(IC).It 

generates energy by burning a mixture of Petroleum and its other products. Due to Which , these vehicle are found out to be a 

one of the replacement for current-generation of vehicles in order to address challenges such as rising pollution, global 

warming, and natural resourcedepletion.Electricalvehiclesare attracting customers due to its environment-friendly nature as it 

does not have an internal-combustion engine which creates harmful gases for the planet, also they have less cost of 

maintenance and they are potential to a tax credit as the customer is cutting down the impact on the environment by choosing 

a zero-emission system. Countries like the United States, China and Japan had updated its policies and standards to support 

the development of EVs. 

II.ELECTRICVEHICLE 

 Electric vehicles in the entire history have never been so in news, and a lot of them can drive many miles just by 

charging only once. In 2008, Tesla introduced the Roadster. Due to many hindrance and faults, it was being able to travel 

which was more than 200km justbychargingonce.ItwasquicklyfollowedbytheMitsubishikilometres in Japan. The creation and 

introduction of these two cars, particularly Tesla, signalled the start of the modernera of electric vehicles. Other major 

automakersrapidly followed behind, developing evs of their own. A vast number of people had already created 

hybrids,suggestingthatthemethodwaswell-established.TheChevroletVoltwasmade by General Motors, and the Nissan Leaf 

was presented by Nissan. Smaller companies, such as Tesla, are pushing significant advancements in electric vehicles [3].An 

electric car can be purchased for a variety of reasons. The motors are whisper quiet, and the trip is wonderfully relaxing. 

Since the power is sent directly to the wheels,  the torque is higher than most people believe. There’s no need to stop at a gas 

station, and while drivers must pay for the electricity needed to charge the car, it’s less expensive than gasoline. 

III.BATTERY MANAGEMENTSYSTEM 
 A battery pack is an arrangement of battery cells electronically arranged in a row  x column matrix format to be able 

to produce a specified range of current and voltage for a given amount of time in response to projected load conditions. The 

following are common BMS responsibilities: 

• BatteryMonitoring 

• Batteryprotection 

• Estimating the operational state of the battery 

• Constantly improving battery performance 

• Reporting operational status to other devices 

 In this situation, the term "battery" refers to the entire pack; nevertheless, in the overall battery pack assembly, 

individual cells or clusters of cells known as modules are subjected to monitoring and control activities. Rechargeable 

lithium-ion cells have the highest energy density and are used in computer and electric car battery packs. They operate well, 

but if used outside of a relatively small safe operating area, they can be harsh, resulting in everything from battery 
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degeneration to outright danger. The BMS does have a difficult job profile, and the complete complexity and oversight it 

requires may include digital, control, electrical, hydraulic, and thermal domains. When constructing a BMS, a number of 

aspects must be taken into account. The entire set of concerns is dependent on the BMS’s intended end application. Apart 

from electric vehicles, BMSs are utilised wherever a lithium battery pack is present, such as in solar panels, wind mills, and 

power walls. ABMS design should take in to account all or many of the following characteristics, regardless of the 

application[5]. 

 

• Controlling Discharge: : A BMS main goal is to keep lithium cells within their safe operating range. A normal Lithium 

18650 cell, for example, will have an undervoltageratingofroughly3V.TheBMSisresponsibleforensuringthatnone of the 

cells in the pack are discharged below3V. 

 

• Charging Control: The BMS should also monitor the charging process in addition to the discharging. When batteries are 

charged incorrectly, they are more likely to be damaged or have a shorter life span. A two-stage charger is used to charge 

lithium batteries. The charger outputs a consistent current to charge the battery in the first stage, which is known as 

Constant Current (CC). When the battery is nearly full, the second stage, known as the Constant Voltage (CV) stage, is 

activated, in which the battery is fed with a constant voltage at a very low current. To avoid overcharging or fast charging 

the batteries, the BMS shouldensurethatboththevoltageandcurrentduringchargingdonotexceedset limitations. The datasheet 

for the battery will tell you what the maximum charging voltage and current are. 

• DeterminationofState-of-Charge(SOC):SOCcanbethoughtofastheelectric vehicle’s fuel gauge. It truly informs us the 

percentage of the pack’s battery capacity. Exactly like the one in our phone. However, it is not as simple as it appears. To 

anticipate the capacity of the battery, the voltage and charge/discharge current of the pack should continually be 

monitored. There are a variety of algorithms that may be used to compute the SOC of the Battery pack once the voltage 

and current have been measured. The coulomb counting approach is the most often used method; we will go over this in 

more detail later in the essay. A BMS is also in charge of measuring the readings and determining the SOC. 

• State-of-Health (SOH) Determination: The capacity of a battery is determined by its age and operating temperature, as 

well as its voltage and current profile. Based on the battery’s usage history, the SOH measurement informs us about the 

battery’s age and predicted life cycle. This allows us to determine how much the EV’smileage(distance travelled after a 

full charge)decreasesasthebatteryages, as well as when the battery pack needs be changed. The SOH should be calculated 

and tracked by the BMS as well. 

 

• Cell Balancing: ABMS’so ther important job is to keep cells balanced. In a pack of four cells connected in series, for 

example, the voltage of all four cells should always be the same. If one cell has a lower or higher voltage than the others, 

the entire pack will suffer. For example, if one cell has 3.5V while the other three have 4V, the entire pack will suffer. 

These three cells will reach4.2V during charging while the other has only reached 3.7V, and this cell will be the first to 

discharge to 3V before the other three. As a result of this solitary cell, all of the other cells in the pack are unable to reach 

their full potential, compromising efficiency. To address this issue, the BMS must perform a process known as cell 

balancing. There are many different types of cell balancing strategies, but the active and passive cell balancing approaches 

are the most popular. The notion behind passive balancing is that cells with excess voltage are forced to discharge through 

a load, such as a resistor, in order to attain the voltage value of the other cells. The stronger cells will be employed to 

charge the weaker cells to equalise their potentials while active balancing is in progress. In a later piece, we’ll go over cell 

balance in further detail. 

 

• Controlling the temperature: The operating temperature of a Lithium battery pack has a considerable impact on its life 

and efficiency. In warmer climates, the battery discharges faster than in normal room temperatures. Adding to this, the use 

of high current would raise the temperature even more. In a battery pack, this necessitates the use of a thermal system 

(usually oil).This thermal system should not only be able to lower temperatures, but also be able to raise them in cold 

climes if necessary. The BMS is in charge of monitoring individual cell temperatures and controlling the thermal system 

to keep the battery pack at a consistent temperature. 

 

• Powered from the Battery itself: The battery is the only source of power in the electric vehicle. As a result, a BMS 

should be built torunon the same battery that it is supposed to preserve and maintain. This may appear easy, but it adds to 

the complexity of the BMS design. 

 

• LessIdealPower: Even if the car is operating, charging, or inoptimal mode, the BMS should be active and functioning. As 

a result, the BMS circuit must be operated continually, and the BMS must consume very little power in order to avoid 

overcharging the battery. When an electric vehicle (EV) is left uncharged for weeks or months, the BMS and associated 

electronics tend to drainthe battery on their own, requiring it to be cranked or charged before usage. Even popular 

automobiles like Tesla are not immune to this challenge. 

 

• Galvanic Isolation: The BMS serves as a link between the EV’s battery pack and its ECU. The ECU must receive all of 

the data collected by the BMS in order for it to be presented on the instrument cluster or dash board. As a result, the BMS 
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and the ECU should be in constant communication, preferably using a standard protocol such as CAN communication or 

the LIN bus. Between the battery pack and the ECU, the BMS should be able to provide galvanicisolation. 

 

• Data Logging: Because the BMS must store a huge amount of data, it requires  a large memory bank. Only if the 

battery’s charging history is known can values liketheSate-of-healthSOHbedetermined.Asaresult,theBMSmustkeeptrack 

ofthebatterypack’schargecyclesandchargetimefromthetimeitwasinstalled, 

andinterruptthisdataasneeded.Thisalsoassistsengineersinofferingafter-sales service or identifying a problem with the EV. 

 

• Accuracy: The voltage across a cell steadily increases or lowers as it is charged or discharged. Unfortunately, a lithium 

battery’s discharge curve (Voltage vs time) has flat portions, resulting in very little voltage change. To determine the 

value of SOC or use it for cell balance, this change must be correctly measured. The precision of a well-designed BMS 

could be as high as 0.2mV, but it should beatleast1mV-2mV.A16-bitADCistypicallyemployedintheprocedure. 

 

• Processing Speed: To determine the value of SOC, SOH, and other parameters, an EV’s BMS must conduct a lot of 

numerical crunching. There are a variety of techniquesforthis,andsomeevenemploymachinelearningtodothework.Asa 

result,theBMSisaprocessor-intensivedevice.Asidefromthat,itmustmeasure cell voltage across hundreds of cells and detect 

minor changes. 

IV.LITERATURE SURVEY 

               Batteries are widely utilized to power electric vehicles, hybrid electric vehicles(HEVs), and many other high-power 

applications. The battery is critical to their efficiency, safety, and reliability. Reliability. Initially, numerous types of batteries 

are discussed in this paper. According to the research, utilised in EVs and HEVs are explored. The most recent battery 

management methods (BMS). Lithium- ion batteries due of their extended life, a preferred source of EVs and HEVs high 

power density density, and good charging and charging efficiency performance discharge However, there are still some 

concerns. Li-ion batteries are used in a variety of applications, includingg complicated  electro chemistry, battery 

deterioration, and battery accuracy health assessment. Vehicle electrification is a global trend that includes Asia and 

Pakistan.Followingthat,thearticleconsiderstheeconomic,environmental,andenergy efficiency implications of increased use of 

electric vehicles [7]. Multiple lithium-ion battery packs operating in parallel are required for large-scale energy storage 

applications. Renewable energy storage systems, battery packs for large-scale automobiles such as electric trucks, tanks, 

armoured vehicles, diesel-electric submarines, and so on are examples of such uses. The existing method for parallel 

operation of numerous battery packs is highly hardware intensive. It necessitates a distinct pack management system acting as 

a master, as well as battery management systems in each of the battery packs deployed as slaves. This has a huge impact on 

the scalability of such systems because the number of battery packs that can be connected in parallel isentirelyreliantonthe 

capacity of the master. A decent ralised pack management system is presented as an alternative in this study. The suggested 

technique eliminates the need for master-slave battery pack configurations and eliminates the need for centralised hardware 

to manage the battery packs. Instead, this system allows individual Battery packs to communicate with one another on their 

own, allowing for decent ralised pack administration[9]. 

 

V.PROPOSED SYSTEM 

 In the proposed system we are going to monitor Battery voltage ,Battery temperature and current. By doing this we 

would be able to see voltage ,current and temperature of the battery every very hour or every minute or whenever we would 

like. When we replace the battery in an electric vehicle at a swapping station, there is no method to check the battery’s health 

card, including how much battery is depleted and how bad the battery is. In this way, anyone can offer us a used or defective 

battery, and we’ll have to accept it without knowing much about it. Since a result, battery prices will be compromised, as 

someone might pay more for a less efficient battery with a shorter life cycle than a more efficient battery with a longer life 

cycle. In this project we are going to use current sensor ,voltage sensor and temperature sensor. We are going to connect the 

current sensor to the battery which would be eventually connected to the PMDC motor .we will do the same thing for 

temperature sensor and voltage sensor respectively. Then we will send the data to Arduino Cloud .Now when we will put the 

throttle on the all the three parameters will be sent to the Arduino cloud from where we will be able to read the data and get 

the various information . 

FIG.1.PROPOSED BLOCK 
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FIG.3.WORKING MODEL 

 

VI.PROPOSED SYSTEM TECHNIQUE 

Connecting the Arduino 

 Connecting an Arduino board to PC is quite simple. On Windows: 

1. Plug in the USB cable - one end to the PC, and one end to the Arduino board. 

2. When prompted, select "Browse my computer for driver" and then select the folder to which you extracted your original 

Arduino IDE download. 

3. You may receive an error that the board is not a Microsoft certified device - select “Install anyway.” 

4. Your board should now be ready for programming. 

When programming your Arduino board it is important to know what COM port the Arduino is using on your PC. 

On Windows, navigate to Start->Devices and Printers, and look for the Arduino. The COM port will be displayed 

underneath. Alternatively, the message telling you that the Arduino has been connected successfully in the lower-left hand 

corner of your screen usually specifies the COM port is it using. 

 
VII.PREPARING THE BOARD 

 Before loading any code to Arduino board, first open the IDE. Double click the Arduino .exe file that downloaded 

earlier. A blank program, or "sketch," should open. 

 The Blink example is the easiest way to test any Arduino board. Within the Arduino window, it can be found 

under File->Examples->Basics->Blink. 

 Before the code can be uploaded to board, two important steps are required. 

1. Select Arduino from the list under Tools->Board. The standard board used in RBE 1001, 2001, and 2002 is the Arduino 

Mega 2560, so select the "Arduino Mega 2560 or Mega ADK" option in the dropdown. 

2. Select the communication port, or COM port, by going to Tools->Serial Port. 

If the COM port in Arduino board is using, it should be listed in the dropdown menu. If not, your board has not finished 

installing or needs to be reconnected. 

 

Loading Code 

The upper left of the Arduino window has two buttons: A checkmark to Verify code, and a right-facing arrow to 

Upload it. Press the right arrow button to compile and upload the Blink example to your Arduino board. 

The black bar at the bottom of the Arduino window is reserved for messages indicating the success or failure of 

code uploading. A "Completed Successfully" message should appear once the code is done uploading to your board. If an 

error message appears instead, check that you selected the correct board and COM port in the Tools menu, and check your 

physical connections. If uploaded successfully, the LED on your board should blink on/off once every second. Most Arduino 

boards have an LED prewired to pin 13.It is very important that you do not use pins 0 or 1 while loading code. It is 

recommended that you do not use those pins ever. 

 

Communication 

The Arduino/Genuino Uno has a number of facilities for communicating with a computer, another Arduino/Genuino 

board, or other microcontrollers. The ATmega328 provides UART TTL (5V) serial communication, which is available on 

digital pins 0 (RX) and 1 (TX).. The 16U2 firmware uses the standard USB COM drivers, and no external driver is needed. 

However, on Windows, a .inf file is required. The Arduino Software (IDE) includes a serial monitor which allows simple 

textual data to be sent to and from the board. The RX and TX LEDs on the board will flash when data is being transmitted 

via the USB-to-serial chip and USB connection to the computer (but not for serial communication on pins 0 and 1). A 

Software Serial library allows serial communication on any of the Uno's digital pins. 

 

Temperature Sensor 

 A humidity sensor senses, measures and regularly reports the relative humidity in the air. It measures both moisture 

and air temperature. Relative humidity, expressed as a percent, is the ratio of actual moisture in the air to the highest amount 

of moisture air at that temperature can hold. The warmer the air is, the more moisture it can hold, so relative humidity 

changes with fluctuations in temperature. 



IoT Based Battery Monitoring System in Electric Vehicle  

139 | P a g e  

 

Most humidity sensors use capacitive measurement to determine the amount of moisture in the air. This type of measurement 

relies on two electrical conductors with a non-conductive polymer film lying between them to create an electrical field 

between them. Moisture from the air collects on the film and causes changes in the voltage levels between the two plates.  

 

 
Fig.4.Circuit Diagram Of Temperature And Humidity Sensor 

Node MCU  
 Node MCU is a LUA based interactive firmware for Express if ESP8622 Wi-Fi SoC, as well as an open source 

hardware board that contrary to the $3 ESP8266 Wi-Fi modules includes a CP2102 TTL to USB chip for programming and 

debugging, is breadboard-friendly, and can simply be powered via its micro USB port. Node MCU is a wifi SO produced 

by Espressif Systems. It is based ESP8266 -12E Wi-Fi module. It is a highly integrated chip designed to provide full internet 

connectivity in a small package. 

 It can be programmed directly through USB port using LUA programming or Arduino IDE. By simple 

programming we can establish a Wifi connection and define input/output pins according to your needs exactly like arduino, 

turning into a web server and a lot more. Node MCU is the Wifi equivalent of Ethernet module. It combines the features of 

Wifi access point and station + microcontroller. These features make the Node MCU extremely powerful tool for WiFi 

networking. It can be used as access point and/or station, host a web server or connect to internet to fetch or upload data. 

 

VIII.SIMULATIONS RESULTS 

 Here in this simulation Figure  a real vehicle like environment is created by the use of MATLAB Simulink to test 

the battery condition under different circumstances. Here we can see we have used a normal dc motor to show the 

functioning of the electric vehicle based on dc motors. A simulated signal is sent to simulate acceleration and breaking in the 

vehicle model. Parameters like kerb weight, vehicle type, number of tyres, are mentioned and are kept in knowledge while 

performing the simulation so that real life like accurate results can be obtained further the battery which is source of power 

for the electric vehicle is connected by the scope which measure current voltage temperature and SOC (state of charge) of the 

battery. These scopes are connected via think speak so that all of the data can be live monitored. 

 

FIG.6.DC MOTORSIMULATION 

 

GRAPH.1.State of Charge Output in Percentage 

 

 

 

 

 

 

 
GRAPH.2.Current output 

IX.CONCLUSION 

https://www.lua.org/about.html
https://www.cnx-software.com/2014/11/17/add-wi-fi-to-arduino-boards-for-3-with-esp8266-wi-fi-serial-module/
http://espressif.com/
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 The proposed system is useful in monitoring and tracking the properties of the battery in real time. The battery plays 

a vital role in an Electric vehicle .Therefore monitoringoftheBatteryisveryimportant.Theprojectproposedanewwaymonitoring 

the battery with the help IOT. The sensors incorporated in the proposed system can collect the data of battery such as voltage, 

temperature and current, these data is then sent to Arduino IOT Cloud . Thus the real time data collection, storage and 

monitoring of the battery of an electric vehicle is possible with the system. By tracking these variables, it will be easier to 

determine the battery’s health or longevity, and pricing will be adjusted accordingly, as a less efficient battery with a shorter 

life cycle will cost morethanamoreefficientbatterywithalongerlifecycle.Thishelpsinidentifyingand solving a problem before a 

failure without human dependency. In addition measured data helps to develop a battery swapping station and its price fixing. 
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